Eclipse einrichten

Dieser Artikel beschreibt wie du deinen Eclipse-Arbeitsbereich (engl.: Workspace) für das Entwickeln von Plugins mit der SpongeAPI und einem Buildsystem wie Maven oder Gradle einrichten kannst.

Bemerkung

Ein Tutorial von Mumfrey zeigt wie du einen Sponge-Workspace in Eclipse erstellen kannst. Dabei werden die neuen Möglichkeiten mit Buildship und ForgeGradle gezeigt. Du kannst es hier anschauen.

Gradle

Gradle vorbereiten

Bemerkung

Gradle ist seit Eclipse Neon (22.06.2016) und später standardmäßig enthalten. Diese Schritte werden nur für frühere Versionen benötigt.

Du musst erst das Gradle Integration Plugin installieren, bevor du Gradle in Eclipse nutzen kannst. Dies muss nur bei der Erstellung deines ersten Projektes getan werden.

Tipp

Normalerweise brauchst du nicht die optionalen Spring Module, die das Plugin mitbringt, weshalb du sie während der Installation nicht ankreuzen brauchst.

  • Starte Eclipse.

  • Klicke auf Help > Eclipse Marketplace.

  • Suche nach Gradle Integration Plugin.

  • Installiere das Gradle Integration Plugin.

Erstelle dein Projekt

  • Starte Eclipse.

  • Drücke File > New > Other.

  • Wähle Gradle > Gradle Project.

  • Klicke Weiter.

  • Gib einen Namen für das Projekt ein, dann drücke Finish.

Build-Skript bearbeiten

  • Öffne build.gradle in der Navigation.

  • Bearbeite das Build-Skript entsprechend der Anleitung in Gradle einrichten.

  • Rechtsklick auf dein Projekt und wähle Gradle > Refresh Gradle Project.

Dein Projekt importieren

Wenn du schon mit deinem Projekt begonnen hast und du es später erneut importieren möchtest, musst du das Projekt importieren anstatt es mit der IDE neu zu erstellen:

  • Klicke Datei > Import

  • Wähle Gradle > Gradle Project

  • Navigiere zum Haupt-Ordner des Projektes

  • Drücke auf Fertig

Maven

Erstelle dein Projekt

  • Starte Eclipse.

  • Drücke File > New > Other.

  • In neu geöffnetem Fenster wähle links Maven und rechts Maven Project.

  • Klicke Weiter.

  • Wähle Create a simple project, es sei denn, du willst ein erweiterte Einstellungen tätigen.

  • Trage deine Group ID, Artifact ID und Version sowie einen Namen und eine Beschreibung für das Project ein.

    • Deine Group ID sollte für gewöhnlich deinem Java-Package-Namen entsprechen. Siehe auch Hauptklasse des Plugins für Details.

    • Deine Artifact ID sollte für gewöhnlich deiner Plugin ID entsprechen, die zuvor gewählt hast, z.B. myplugin.

    • Die Version kannst du selbst nach Belieben festlegen.

  • Click Finish.

Tipp

Oft öffnet Eclipse neu erstellte Projekte nicht, nachdem du sie erstellt hast. Sollte dies der Fall sein, versuche, den Willkommensbildschirm zu schließen; dein Projekt ist wahrscheinlich hinter diesem versteckt.

Projektkonfiguration editieren

  • Öffne die pom.xml im Navigator.

  • Bearbeite die Build-Konfiguration entsprechend der Anleitung in Maven einrichten.

  • Lade dein Maven-Projekt neu.

Dein Projekt importieren

Wenn du schon mit deinem Projekt begonnen hast und du es später erneut importieren möchtest, musst du das Projekt importieren anstatt es mit der IDE neu zu erstellen:

  • Klicke Datei > Import

  • Wähle Maven > Existing Maven Projects

  • Navigiere zum Haupt-Ordner des Projektes

  • Drücke auf Fertig

Git-Integration

Die Eclipse Foundation bietet Dokumentationen, welche beschreiben, wie man das Eclipseplugin EGit verwendet:

https://www.eclipse.org/egit/documentation/