APIのバージョン

このページではどのAPIのバージョンが存在しているか、そしてそれらの実装がどのMinecraftのバージョンに属するかを説明しています。

APIのバージョン 公開日 サポートの終了日 実装 (Minecraftのバージョン)
8.0.0 未定 未定
  • SpongeForge
  • SpongeVanilla
7.2.0 未定 未定
  • SpongeForge (1.12.2)
  • SpongeVanilla (1.12.2)
7.1.0 2018年9月6日 未定
  • SpongeForge (1.12.2)
  • SpongeVanilla (1.12.2)
7.0.0 2018年1月18日 Sep 5, 2018
  • SpongeForge (1.12.2)
  • SpongeVanilla (1.12.2)
6.0.0 2017年5月2日 2017年12月31日
  • SpongeForge (1.11.2)
  • SpongeVanilla (1.11.2)
5.1.0 2017年2月25日 2017年12月31日
  • SpongeForge (1.10.2)
  • SpongeVanilla (1.10.2)

常に最新の安定したバージョンのAPI、またはLSTバージョンを更新して下さい。

注釈

You may still choose to develop and release plugins against versions that have reached the end of support, but the Sponge team will not provide bug fixes or features to unsupported builds.

Getting the API Version from Implementations

Getting it from the Jar

See Versioning.

Getting the Minecraft Version from Implementations

Getting it from the Sources

  • For SpongeForge or SpongeVanilla:

    Go to the referenced SpongeCommon repository and check the gradle.properties in the project root. It contains an entry with the minecraftVersion.

    注釈

    The same works for the mcpMappings version.

  • For SpongeVanilla (only):

    Check the gradle.properties in the project root. It contains an entry with the minecraftVersion.