Instalar o JDK

O Java Development Kit - também conhecido como JDK - é necessário para desenvolver plugins para o Sponge e/ou para desenvolver o próprio Sponge.

Download

Antes de instalar o JDK, desinstale todas as versões do Java mais antigas que estejam no seu computador.

Nota

Os contribuidores do Sponge e os autores de Plugins têm de usar o JDK 8, uma vez que as versões antigas do Java já não são suportadas. Tem em mente que alguns servidores de Minecraft ainda não migraram para Java 8. Para usares o Sponge e os seus plugins corretamente, deverás atualizar para o Java 8, pois o Sponge não corre nas versões mais antigas (ex. Java 6 e 7).

A Oracle oferece downloads gratuitos do Java Development Kit no seu site. Certifique-se de que está a instalar o JDK (Java Development Kit), e não o JRE (Java Runtime Environment). Há uma diferença entre os dois.

Depois do processo de instalação estar concluído, reinicie o seu computador. O JDK deverá estar pronto para utilizar após esta operação.