依赖底层实现

绕开 SpongeAPI,并直接调用 Minecraft 的底层实现,的理由,有很多

  • SpongeAPI 的实现不全。这个时候你也只能选择直接调用底层了。然而,请考虑一下别的可能性——比如直接帮 Sponge 实现你需要的 API——同样是写代码解决一个问题,后者可以让更多的开发者受益。

  • 你需要与实现平台有关的特性。很明显,平台无关的 SpongeAPI 不会提供这样的功能。

  • 你的实现需要针对你的服务器进行优化或个性化。

警告

直接依赖底层实现的一个直接后果,便是你的插件只能在你所依赖的平台(甚至是特定版本)上工作。正因如此,我们建议你不要轻易这么做——除非你确定你已经别无选择。

注解

下列文章均建基于如下假设上:你的插件需要依赖 SpongeVanilla 或者 SpongeForge,且无法在其他 Sponge 实现上运行。

SpongeVanilla 和 SpongeForge 均在其运行时中用到了 MCP。MCP 简介一文对 MCP 作了简介;而在插件中使用 MCP 一文则介绍了在插件开发中使用 MCP 的方法。